Skip to content

AU

FREE SHIPPING ON ORDERS OVER $550 IN SELECTED AREAS

3fbde98138f1a5a709a83e1c5e9aec69.jpg

TP-Link Omada 8-Port Gigabit Smart Switch with 4-Port PoE+

Regular price $186.14
Sale price Regular price

Key specifications

  • Product colour: Black
  • Switch type: Managed
  • Operating temperature (T-T): 0 - 40 °C
  • Operating relative humidity (H-H): 10 - 90%
  • Networking standards: IEEE 802.1D, IEEE 802.1Q, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.1x, IEEE 802.3ab, IEEE 802.3ad, IEEE 802.3af, IEEE 802.3at, IEEE 802.3i, IEEE 802.3u, IEEE 802.3x
  • Basic switching RJ-45 Ethernet ports quantity: 8
  • Basic switching RJ-45 Ethernet ports type: Gigabit Ethernet (10/100/1000)
  • Power over Ethernet (PoE): Yes
  • Switching capacity: 16 Gbit/s
  • MAC address table: 8000 entries
  • 10G support: No
  • Storage relative humidity (H-H): 5 - 90%
  • LED indicators: Yes
  • Quality of Service (QoS) support: Yes
  • Rack mounting: Yes
  • Flow control support: Yes
  • Jumbo frames support: Yes
  • Switch layer: L2/L2+
  • Forwarding rate: 11.9 Mpps
  • Jumbo frames: 9000

Certificates

Certification
CE, FCC, RoHS

Data transmission

Number of queues
8
Packet buffer memory
4.1MB

Management features

ARP inspection
Yes
MIB support
MIB II (RFC1213) Bridge MIB (RFC1493) P/Q-Bridge MIB (RFC2674) Radius Accounting Client MIB (RFC2620) Radius Authentication Client MIB (RFC2618) Remote Ping, Traceroute MIB (RFC2925) Support TP-Link private MIBs RMON MIB(RFC1757, rmon 1,2,3,9)
System event log
Yes
Web-based management
Yes

Multicast features

Multicast support
Yes

Network

Auto-negotiation
Yes
Auto MDI/MDI-X
Yes
Broadcast storm control
Yes
Link aggregation
Yes
Number of VLANs
4094
Port mirroring
Yes
Rate limiting
Yes
Spanning tree protocol
Yes
VLAN support
Yes

Operational conditions

Heat dissipation
263.6 BTU/h
Storage temperature (T-T)
-40 - 70 °C

Packaging content

Manual
Yes

Packaging data

Package type
Box

Performance

Fanless
Yes

Power

Power consumption (max)
77.3 W
Power supply included
Yes

Power over Ethernet (PoE)

Power over Ethernet plus (PoE+) ports quantity
4

Protocols

IPv4 & IPv6 features
IPv6 Telnet, IPv6 ping, IPv6 tracert
Management protocols
SNMPv1/v2c/v3

Security

Authentication
MAC-based authentication, Web-based authentication
Authentication type
RADIUS
DHCP features
DHCP client, DHCP relay, DHCP snooping, DHCPv6 server, DHCPv6 snooping
IGMP snooping
Yes
MAC address filtering
Yes
Security algorithms
802.1x RADIUS

Weight & dimensions

Depth
12.6 cm
Height
2.6 cm
Width
20.9 cm

THE NUTEC ADVANTAGE

VENDOR NEUTRAL

Advice focused on the solution that best fits your business needs.

END TO END DELIVERY

From selection through implementation, support, and beyond.

BUSINESS FIRST OUTCOMES

Delivering solutions focused on measurable outcomes.

LONG TERM PARTNERSHIP

Built on trust, support, and shared success.

Compare With Similar Items

Description
TP-Link’s brand new Omada smart switches provide huge upgrade comparing with previous versions. The switches can be managed by Omada SDN Controller, which provides professional and reliable one-step solutions. Integrated L2 and L2+ features such as 802.1Q VLAN, QoS, IGMP Snooping and static routing provide cost-effective networking solutions for small and medium-sized businesses without sacrificing enhanced usability and strong performance.
The TL-SG108E 8-Port Gigabit Easy Smart switch is an ideal upgrade from an Managed switch, designed for Small and Medium Business networks that require simple network management. Network administrators can effectively monitor traffic via Port Mirroring, Loop Prevention and Cable Diagnostics features. To optimize traffic on your business network, TL-SG108E offers both port and tag based QoS to keep latency-sensitive traffic moving smoothly and jitter-free. Additionally, port-based, tag-based and MTU VLAN can improve security and meet more network segmentation requirements. Moreover, with its innovative energy-efficient technology, the TL-SG108E can save up to 80% of power consumption, making it an eco-friendly solution for your business network.

Simple & Effective Management
TP-LINK’s Gigabit Easy Smart switch, TL-SG108E offers network monitoring for users to observe traffic behavior. With Port Mirroring, Loop Prevention and Cable Diagnostics features, TL-SG108E can identify and even locate connection problems on your business network. Moreover, administrators can designate the priority of the traffic based on Port Priority and 802.1P Priority, to ensure that voice and video are always clear, smooth and lag-free. Additionally, to improve security and network performance, TL-SG108E supports MTU VLAN, port-based VLAN and 802.1Q-based VLAN functions. TL-SG108E is an upgrade from the plug-and-play Managed Switch, delivering great value while empowering your network and similarly delivering great value to the end user.

Go Green with Your Ethernet
You now have the choice to go green when upgrading to a gigabit network! This new generation of TL-SG108E 8-Port Gigabit Easy Smart Switch features the latest energy-efficient technologies that can greatly expand your network’s capacity with much less power. It automatically adjusts power consumption according to the link status and cable length to limit the carbon footprint of your network.

Power down Idle Ports
When a computer or network equipment is off, the corresponding port of a traditional switch will continue to consume considerable amounts of power. The TL-SG108E can automatically detect the link status of each port and reduce the power consumption of ports that are idle.

Power Budget According to Cable Length
Ideally, shorter cables would use less power with less power degradation over their length; this is not the case with most devices as they will use the same amount of power across the cable regardless of whether it is 10 or 50 meters in length. The TL-SG108E analyzes the length of the Ethernet cable connected and adjusts the power usage accordingly, rather than keeping the power consumption in a conventional solution.

Ease of Use
TL-SG108E is easy to use and manage. Auto MDI/MDI-X crossover on all ports eliminate the need for crossover cables or uplink ports. Auto-negotiation on each port senses the link speed of a network device (either 10, 100, or 1000 Mbps) and intelligently adjusts for compatibility and optimal performance. Its compact size makes it ideal for desktops with limited space while also being Rack-mountable, convenient and safe. Dynamic LED lights provide real-time work status display and basic fault diagnosis.
- 8 10/100/1000Mbps Auto-Negotiation RJ45 ports supporting Auto-MDI/MDIX
- Green Ethernet technology saves the power up to 82%
- IEEE 802.3x flow control provides reliable data transfer
- Steel housing, desktop or wall-mounting design
- Support 802.1p/DSCP QoS1 and IGMP Snooping function1
- Plug and play, no configuration needed

What This Product Does

The TP-LINK 8 10/100/1000Mbps Desktop Switch TL-SG108 provides you an easy way to make the transition to gigabit Ethernet. Increase the speed of your network server and backbone connections, or make gigabit to the desktop a reality. Moreover, TL-SG108 adopts lower power consumption design. With the innovative energy-efficient technology, the TL-SG108 can save up to 82% of the power consumption, making it an eco-friendly solution for your home or office network.
Gigabit Switch
Featured with 8 10/100/1000Mbps ports, TL-SG108 greatly expands your network capacity, enabling instant large files transferring. So,power users in the home, office, workgroup, or creative production environment can now move large, bandwidth-intensive files faster. Transfer graphics, CGI, CAD, or multimedia files across the network instantly.

Go Green With Your Ethernet

You now have the choice to go green when upgrading to a gigabit network! This new generation TL-SG108 features the latest innovative energy-efficient technologies that can greatly expand your network capacity with much less power. It automatically adjusts power consumption according to the link status and cable length to limit the carbon footprint of your network.
Power down Idle Ports
When a computer or network equipment is off, the corresponding port of a traditional switch will continue to consume considerable amounts of power. The TL-SG108 can automatically detect the link status of each port and reduce the power consumption of ports that are idle, resulting in up to an 82% reduction in power use.
Power Budget According to Cable Length
Ideally, shorter cable would use less power because of less power degradation over their length; this is not the case with most devices as they will use the same amount of power across the cable regardless of the length.

Traffic Optimization
802.1p and DSCP QoS1 enable smooth latency-sensitive traffic such as voice and video, and IGMP Snooping1 optimizes the Multicast data stream.

Easy to Use

The auto features of this gigabit switch make installation plug and play and hassle-free. No configuring is required. Auto MDI/MDIX eliminate the need for crossover cables. Auto-negotiation on each port senses the link speed of a network device (either 10, 100, or 1000 Mbps) and intelligently adjusts for compatibility and optimal performance.
The TL-SG105PE is an 5-port Gigabit Easy Smart Switch with 4 PoE+ ports, represents a powerful upgrade from an unmanaged switch. It is designed specially for small businesses that require simple network management and PoE function. The TL-SG105PE can connect and power up to four PoE devices, such as wireless access points (APs), IP cameras, and IP phones. Through its web-based user interface and management utility, the TL-SG105PE offers a variety of useful features, including network monitoring, traffic prioritization, PoE Auto Recovery and enhanced QoS. Additionally, with port-based, tag-based and MTU VLAN, TL-SG105PE can improve security and meet more network segmentation requirements.

Power Over Ethernet
4 of the 5 Auto-Negotiation RJ45 ports (port 1 to port 4) of the switch support Power over Ethernet (PoE) function. These PoE ports can automatically detect and supply power with those IEEE 802.3af/at compliant Powered Devices (PDs).

Overload Arrangement
TL-SG105PE has the priority function which will help protect the system when the system power is overloaded. If all PoE PDs power consumption is >= 65 W, a priority will be arranged among the PoE ports, then the system will cut off the power of the lowest-priority port.

Intelligent Power Management
Priority (port 1>port 2>port 3>port 4): This function will help protect the system if the system power becomes overloaded. For example, Port 1, 2 and 4 are consuming 15.4 W respectively. If an additional PoE device with 20 W is inserted to port 3, the system will cut off the power of port 4 to compensate for the overload.

Effective Management
TL-SG105PE offers network monitoring for users to observe traffic behavior. Through its web-based user interface and management utility, the TL-SG105PE offers a variety of useful features, including network monitoring, traffic prioritization, PoE Auto Recovery and enhanced QoS.
With Port Mirroring, Loop Prevention and Cable Diagnostics features, TL-SG105PE can identify and even locate connection problems on your business network. Also, administrators can designate the priority of the traffic based on Port Priority, 802.1P Priority and DSCP Priority, to ensure that voice and video are always clear, smooth and lag-free.
Additionally, to improve security and network performance, TL-SG105PE supports MTU VLAN, port-based VLAN and 802.1Q-based VLAN functions. PoE Auto Recovery automatically reboots your dropped or unresponsive PoE-powered devices.
TL-SG105PE is an upgrade from the plug-and-play Unmanaged Switch, delivering great value while empowering your network and similarly delivering great value to the end user.

Easy to Use
TL-SG105PE is easy to use and manage. Auto MDI/MDI-X crossover on all ports eliminate the need for crossover cables or uplink ports. Auto-negotiation on each port senses the link speed of a network device (either 10, 100, or 1000 Mbps) and intelligently adjusts for compatibility and optimal performance. Its compact size makes it ideal for desktops with limited space. Dynamic LED lights provide real-time work status display and basic fault diagnosis.
TP-Link 5-Port Gigabit Easy Smart Switch with 4-Port PoE+. Switch layer: L2. Basic switching RJ-45 Ethernet ports type: Gigabit Ethernet (10/100/1000), Basic switching RJ-45 Ethernet ports quantity: 5. MAC address table: 2000 entries, Switching capacity: 10 Gbit/s. Networking standards: IEEE 802.1Q, IEEE 802.1p, IEEE 802.3ab, IEEE 802.3af, IEEE 802.3at, IEEE 802.3i, IEEE 802.3u, IEEE.... DC input voltage: 53.5 V. Power over Ethernet (PoE)
Price
Regular price $186.14
Sale price Regular price
Regular price $88.47
Sale price Regular price
Regular price $70.64
Sale price Regular price
Regular price $101.81
Sale price Regular price
Regular price $133.10
Sale price Regular price
Product variants

Special Offer

FREE SHIPPING ON ORDERS OVER $550 IN SELECTED AREAS

Explore our FAQ

Contact Us

Where do the specifications come from?

Product specifications are sourced from Icecat and displayed only when supporting data is available. Where information is missing, the field is left blank rather than populated with estimated or inferred values.

A Partnership-First Approach

At NUTEC, we take a partnership-first approach to every engagement. We start by understanding your business - its challenges, priorities, and long-term goals before recommending any technology solution. From workplace modernization and cloud infrastructure to cyber security and systems integration, our team works closely with you at every stage, ensuring the right technology is procured, implemented, and supported with clarity and confidence. We believe in transparent communication, tailored outcomes, and building lasting partnerships that grow with your business.

Opening Hours

Mon - Fri, 9:00AM - 5:00PM AEST

Phone

0401 113 232

Email

sales@nutec.com.au

Address

Online Store