Skip to content

AU

FREE SHIPPING ON ORDERS OVER $550 IN SELECTED AREAS

93821235_9246860719.jpg

Yealink SIP-T58W IP phone Grey LCD Wi-Fi

Regular price $649.67
Sale price Regular price

Key specifications

  • Display diagonal: 17.8 cm (7")
  • Display resolution: 1024 x 600 pixels
  • Product colour: Grey
  • Display: LCD
  • Product type: IP Phone
  • Speakerphone: Yes
  • Handset type: Wired handset
  • Operating relative humidity (H-H): 10 - 95%
  • Voice codecs: G.711a, G.722, G.723.1, G.726, G.729, G.729A, G.729B, iLBC
  • Caller ID: Yes
  • Number of handles included: 1 pc(s)
  • Touchscreen: Yes
  • Ethernet LAN (RJ-45) ports: 2
  • Ethernet LAN: Yes
  • Ethernet LAN interface type: Gigabit Ethernet
  • Power over Ethernet (PoE): Yes
  • Ethernet LAN data rates: 1000 Mbit/s
  • Bluetooth: Yes
  • RJ-9 ports quantity: 2
  • Security algorithms: 256-bit AES, HTTPS, TLS, WPA2, WPA3

Audio

Adaptive jitter buffers
Yes
Automatic gain control
Yes
Comfort noise generation (CNG)
Yes
Microphone mute
Yes
Noise reduction
Yes
Packet loss concealment (PLC)
Yes
Voice activity detection
Yes

Camera

Field of view (FOV) angle
75°
Front camera
Yes
Front camera resolution (numeric)
5 MP

Design

Wall mountable
Yes

Display

Touchscreen type
Capacitive

Logistics data

Harmonized System (HS) code
85171800

Management features

Integrated voicemail
Yes
Keypad number of keys
27
Number of function keys
7

Network

Bluetooth version
4.2
Networking standards
IEEE 802.11a, IEEE 802.11b, IEEE 802.11g, IEEE 802.11n, IEEE 802.1x, IEEE 802.3af
Quality of Service (QoS) support
Yes
Supported network protocols
IPv4/IPv6, SIP v1 (RFC2543), v2 (RFC3261), UDP/TCP/DNS-SRV (RFC 3263)
Wi-Fi
Yes
Wi-Fi standards
802.11a, 802.11b, 802.11g, Wi-Fi 4 (802.11n)

Operational conditions

Operating temperature (T-T)
0 - 40 °C

Performance

Dual-Tone Multi-Frequency (DTMF) modes
In-band, Out-of band, SIP info
Hearing aid compatibility
Yes

Phone features

Anonymous call
Yes
Anonymous call rejection
Yes
Answering machine
Yes
Call forwarding
Yes
Call hold
Yes
Call park
Yes
Call pick up
Yes
Call return
Yes
Call transfer
Yes
Call waiting
Yes
Conference call
Yes
Do not disturb function
Yes
Full duplex
Yes
Intercom
Yes
Message-waiting indicator (MWI)
Yes
Phonebook capacity
1000 entries
Redialing
Yes
Speed dialling
Yes

Ports & interfaces

USB 2.0 ports quantity
2

Video

Video codecs
H.264 High Profile, H.264, VP8
Video resolutions
1280 x 720 pixels

Weight & dimensions

Depth
22 cm
Height
23.9 cm
Package depth
29.3 cm
Package height
12.8 cm
Package weight
9.86 kg
Package width
32.4 cm
Weight
9.16 kg
Width
25.94 cm

THE NUTEC ADVANTAGE

VENDOR NEUTRAL

Advice focused on the solution that best fits your business needs.

END TO END DELIVERY

From selection through implementation, support, and beyond.

BUSINESS FIRST OUTCOMES

Delivering solutions focused on measurable outcomes.

LONG TERM PARTNERSHIP

Built on trust, support, and shared success.

Compare With Similar Items

Description
Free from Cord Constraint, Free from Distracting Noise

Adopting the innovative Bluetooth handset, Yealink T58W Pro pervades wireless communication by allowing the user to move around freely and conveniently.

The professional hardware and the cutting-edge acoustic algorithm of Yealink makes the T58W Series an expert at eliminating noise and keeping every conversation clear and focus.

Take Smart Business Phone to the Next Level
Boost by the upgraded chipsets, the T58W Series comes with enhanced system performance with fast response and reinforced processing capacity. The adoption of Android 9.0 OS also improves the data encryption, authority management, response speed and integratability to meet requirements of modern business and future sustainability.

Enterprise-level Security, Provision and Management
Taking data security as one of the most significant concerns, the new set of phones adopt Arm TrustZone technology to safeguard various ARM-based data and applications.

By supporting Yealink/Unify Square Device Management Platform, the management, provision and update of the T58W Series can be implemented in a streamlined and simplified manner.
Dial up your productivity
Get to work fast with the 7-in color multi-touch LCD display. And with the simple and intuitive interface, Bluetooth connectivity, integrated Wi-Fi, and Poly quality audio you’re ready in a snap.
Call with confidence
Sleek design meets quality audio at an affordable price. Easy-to-use illuminated keys, plug-and-play provisioning, and reliability make it pure value.
Rethink the cordless phone
Your team is on the move in the office and needs a handset that keeps up. Get all the business features from a desk phone at your fingertips. Everyone on the call will experience clear, interruption-free conversations. So, work gets done.
Scalable. Secure. Safe
Secure your conversations with the Poly Rove B4 base station DECT ™ end-to-end encryption. Built for enterprise deployments and compatible with any of the Poly Rove handsets and the Rove R8 repeater, the Rove B4 base station keeps teams going.
Price
Regular price $649.67
Sale price Regular price
Regular price $921.66
Sale price Regular price
Regular price $133.26
Sale price Regular price
Regular price $302.48
Sale price Regular price
Regular price $634.05
Sale price Regular price
Product variants

Special Offer

FREE SHIPPING ON ORDERS OVER $550 IN SELECTED AREAS

Explore our FAQ

Contact Us

Where do the specifications come from?

Product specifications are sourced from Icecat and displayed only when supporting data is available. Where information is missing, the field is left blank rather than populated with estimated or inferred values.

A Partnership-First Approach

At NUTEC, we take a partnership-first approach to every engagement. We start by understanding your business - its challenges, priorities, and long-term goals before recommending any technology solution. From workplace modernization and cloud infrastructure to cyber security and systems integration, our team works closely with you at every stage, ensuring the right technology is procured, implemented, and supported with clarity and confidence. We believe in transparent communication, tailored outcomes, and building lasting partnerships that grow with your business.

Support Hours

Mon–Fri, 9am–5pm AEST

Phone

0401 113 232

Email

sales@nutec.com.au

Address

Online Store